Polywebster Logo

Installation des PolyCharts Connector-Paketes

Anleitung zum Installieren des PolyChart-Connectors

Installationsvoraussetzungen

Das Connector-Paket bindet jqPlot an das papaya CMS an. Installationsvoraussetzung ist eine papaya CMS-Installation (v5.4 weitere Informationen siehe papaya CMS Dokumentation). Zudem wird das unter GPL v2.0 veröffentlichte PolyBase-Framework benötigt, welches Sie ebenfalls hier he­run­terladen können. Bitte folgen Sie der dort beigefügten Installationsanleitung und fahren Sie an­schließend mit der Installation fort.

 

Installation de PolyChart-Connectors

Das Paket lässt sich in wenigen Schritten auf einem papaya CMS-System installieren. Nachdem Sie das Paket (v1.2) heruntergeladen und entpackt haben, verschieben Sie das Verzeichnis "poly_charts" in Ihre papaya CMS-Installation in das Verzeichnis ./papaya-lib/modules/free.

 

Das Connectormodul  muss am papaya CMS angemeldet werden. Hierfür benutzen Sie die Modul-Verwaltung im papaya CMS-Backend ("Module"). Wählen Sie hier "Module suchen", um die Module automatisch suchen und einbinden zu lassen.

 

 

Einbinden der Übersetzungen

Die Übersetzungen für die Module liegen als SQL-Dump vor (poly_charts_trans.sql) und können vom Administrator in die Datenbank eingespielt werden.

 

 

Modul konfigurieren

Als nächstes sind unter "Module" -- poly_charts connector_jqplot --  "Optionen" die notwendigen Rahmenparameter anzugeben. Hier muss u.a. der Pfad eingetragen werden, unter dem ein Browser die jqPlot Bibliothek auf dem Server findet.

Poly-Charts für papaya CMS

Paketinhalt im Überblick:

  • Connector für jqPlot Javascript
  • Unterstütze Diagrammtypen:
    • Tortendiagramme
    • Balkendiagramme
    • Liniendiagramme
    • Punktdiagramme